Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone nodes Beijing, CN - China Mobile maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Aug 22, 2018 - 10:53 EDT
Investigating
Catchpoint Backbone nodes Beijing, CN - China Mobile will not run tests due to a scheduled network maintenance.
Posted Aug 17, 2018 - 12:32 EDT