Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone nodes Beijing, CN - China Telecom maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Nov 15, 2018 - 22:11 EST
Investigating
Catchpoint Backbone nodes Beijing, CN - China Telecom will not run tests due to a scheduled network maintenance.
Posted Nov 15, 2018 - 04:38 EST