Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone nodes Zhengzhou, CN - China Mobile offline
Incident Report for Catchpoint Systems Services Page
Resolved
Zhengzhou, CN - China Mobile is back online for customers to run tests.
Posted Dec 06, 2017 - 06:46 EST
Investigating
Catchpoint Backbone node Zhengzhou, CN - China Mobile will not run tests due to a network issue.
Posted Nov 28, 2017 - 06:00 EST