Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone nodes Sofia, BG - Neterra maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Dec 13, 2017 - 07:21 EST
Investigating
Catchpoint Backbone nodes Sofia, BG - Neterra will not run tests due to a scheduled network maintenance.
Posted Dec 13, 2017 - 06:14 EST