Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Support Portal Down
Incident Report for Catchpoint Systems Services Page
Resolved
Zendesk has resolved their issues. Catchpoint Support is back up as expected.
Posted Mar 21, 2016 - 11:39 EDT
Investigating
Catchpoint Help Portal (Powered by Zendesk) is Currently Down. Please use support@catchpoint.com to submit support requests. We will update as we know more. We apologize for any inconvenience.

Zendesk Ops Twitter:
https://twitter.com/ZendeskOps

Zendesk Status Page:
https://support.zendesk.com/hc/en-us/articles/218190017-Service-Incident-March-21st-2016
Posted Mar 21, 2016 - 10:11 EDT