Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone node Sofia, BG - Neterra ISP maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Feb 12, 2018 - 05:04 EST
Investigating
Catchpoint Backbone node Sofia, BG - Neterra will not run tests due to a scheduled network maintenance.
Posted Feb 09, 2018 - 09:11 EST