Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone nodes Chengdu, CN - Telecom maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Jul 16, 2018 - 04:10 EDT
Investigating
Catchpoint Backbone nodes Chengdu, CN - Telecom will not run tests due to a scheduled network maintenance.
Posted Jul 02, 2018 - 03:16 EDT