Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone node Shenzhen, CN - Unicom maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Sep 16, 2018 - 23:49 EDT
Identified
Catchpoint Backbone node Shenzhen, CN - Unicom will not run tests due to a routing issue identified on the node. We are working with ISP to fix this as soon as possible.
Posted Aug 10, 2018 - 01:17 EDT