Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone node Helsinki, FI - RETN paused
Incident Report for Catchpoint Systems Services Page
Resolved
Helsinki, FI - RETN node is back online and running tests.
Posted Mar 14, 2018 - 02:37 EDT
Identified
Catchpoint Backbone node Helsinki, FI - RETN will not run tests due to a network maintenance at ISP side.
Posted Mar 13, 2018 - 02:22 EDT