Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone node Accra, GH- BusyInternet paused
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Dec 05, 2017 - 23:43 EST
Identified
Catchpoint Backbone node Accra, GH- BusyInternet will not run tests due to network issues at ISP side.
Posted Dec 05, 2017 - 09:19 EST