Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone nodes Amsterdam, NL - DTAG maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Mar 08, 2018 - 01:58 EST
Investigating
Catchpoint Backbone nodes Amsterdam, NL - DTAG will not run tests due to a scheduled network maintenance.
Posted Mar 08, 2018 - 01:25 EST