Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone node Algiers, DZ - Sarl Icosnet unplanned maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
The service availability of Icosnet ISP in Algiers have significantly degraded and the provider cannot offer a stable solution.

As of 21-Dec-2018, the node is switched to EDX Network ISP.
Posted Dec 21, 2018 - 03:29 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 20, 2018 - 21:15 EST
Identified
The issue has been identified as ISP Outage from the datacenter end. Fix will be implemented soon.
Posted Dec 14, 2018 - 01:55 EST
Investigating
Catchpoint Backbone node Algiers, DZ - Sarl Icosnet have been paused due to an unplanned maintenance at provider end and will not run tests. We will update the status as soon as there is additional information available.
Posted Nov 21, 2018 - 12:19 EST