Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone node Shenyang, CN - Unicom maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Jul 11, 2018 - 11:34 EDT
Investigating
Catchpoint Backbone node Shenyang, CN - Unicom will not run tests due to an unplanned maintenance at provider end.
Posted Jul 02, 2018 - 02:43 EDT