Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone nodes Denver - Comcast maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Feb 14, 2018 - 15:53 EST
Investigating
Catchpoint Backbone nodes Denver - Comcast will not run tests due to a scheduled network maintenance.
Posted Feb 14, 2018 - 03:19 EST