Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone node Frankfurt, DE - Vodafone maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
Frankfurt, DE - Vodafone is back online and running tests.
Posted Jun 14, 2018 - 02:21 EDT
Identified
Catchpoint Backbone node Frankfurt, DE - Vodafone will not run tests due to a scheduled network maintenance.
Posted Jun 12, 2018 - 06:09 EDT