Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone nodes Philadelphia, US - Cogent maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted May 15, 2020 - 13:30 EDT
Investigating
Catchpoint Backbone nodes Philadelphia, US - Cogent will not run tests due to a scheduled network maintenance.
Posted May 15, 2020 - 12:47 EDT