Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone node New York, USA - Verizon unplanned maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Dec 05, 2019 - 17:17 EST
Investigating
We are performing unscheduled maintenance on New York, USA - Verizon Backbone node.
Posted Dec 05, 2019 - 16:56 EST