Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone node "New York, USA - Verizon" unplanned maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Dec 12, 2019 - 15:16 EST
Investigating
We are performing unscheduled maintenance on "New York, USA - Verizon" Backbone node
Posted Dec 12, 2019 - 14:16 EST