Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone nodes Harbin, CN - China Mobile maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Jul 15, 2019 - 19:49 EDT
Identified
Catchpoint Backbone nodes Harbin, CN - China Mobile will not run tests due to a scheduled network maintenance.
Posted Jul 15, 2019 - 02:58 EDT