Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Chrome Browser Version Switch Rollback
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Mar 19, 2019 - 15:42 EDT
Monitoring
The rollback is completed and we are monitoring results.
Posted Mar 19, 2019 - 14:57 EDT
Investigating
We are rolling back our Chrome browser version switch to stable 66 and preview 71 as some tests on a CDN with specific debug headers are causing connection errors on the browser.
Posted Mar 19, 2019 - 14:34 EDT