Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Node Singapore, SG - PCCW - Paused for maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
The node will be transitioning to China Mobile on 31st July.
Posted Jul 31, 2018 - 02:11 EDT
Investigating
We are currently investigating this issue.
Posted Jul 09, 2018 - 17:23 EDT