Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Backbone nodes Jakarta, ID - PT Telekom maintenance
Incident Report for Catchpoint Systems Services Page
Resolved
Maintenance has completed. We have put the device back into production.
Posted May 15, 2018 - 13:51 EDT
Investigating
Catchpoint Backbone nodes Jakarta, ID - PT Telekomwill not run tests due to a scheduled network maintenance.
Posted Apr 12, 2018 - 09:05 EDT