Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Catchpoint Portal Issue
Incident Report for Catchpoint Systems Services Page
Resolved
Both the Portal and API are available again.

Please contact us at support@catchpoint.com if you have any questions.
Posted Mar 10, 2023 - 09:14 EST
Update
The Catchpoint Portal has been up and stable over the last 18 hours, we will continue to monitor.

We’re still actively troubleshooting an issue with the API.

Please contact us at support@catchpoint.com if you have any questions.
Posted Mar 09, 2023 - 09:35 EST
Update
We continue to experience intermittent outages to the Catchpoint Portal, API, WebPageTest.org and Support due to a highly complex Distributed Denial of Service (DDoS) attack. The entire Catchpoint team is actively working with DDoS mitigation experts to deflect the attack. Your test data, RUM and test alerts are not impacted.

We’ll post updates here as they become available.
Posted Mar 08, 2023 - 09:37 EST
Update
The issue is on going, we are actively troubleshooting and will post updates as they become available.
Posted Mar 08, 2023 - 08:58 EST
Investigating
We are aware of issues with accessing the Catchpoint Portal. We are currently looking into it.
Posted Mar 08, 2023 - 06:24 EST
Update
The Catchpoint Portal is available again. We are monitoring for stable results.
Posted Mar 07, 2023 - 19:49 EST
Update
We are aware of issues with accessing the Catchpoint Portal. We are actively investigating and will post updates as we receive more information.
Posted Mar 07, 2023 - 19:40 EST
Update
We are continuing to monitor for any further issues.
Posted Mar 07, 2023 - 19:40 EST
Update
The issue is resolved now and the Catchpoint Portal is available again. We're monitoring the situation to ensure stability.
Posted Mar 07, 2023 - 17:30 EST
Update
We are actively troubleshooting the issue still and will post new updates as we receive more information.
Posted Mar 07, 2023 - 16:10 EST
Update
We are aware of issues with accessing the Catchpoint Portal. We are actively investigating and will post updates as we receive more information.
Posted Mar 07, 2023 - 13:19 EST
Update
Catchpoint APIs are working now and we are continuously monitoring for any issues.
Posted Mar 07, 2023 - 12:51 EST
Update
We are aware of issues with the API service and are investigating. We will post updates as we receive more information.

API IP whitelisting functionality is not currently working - customers can remove IP whitelist temporarily until this issue is resolved.
Posted Mar 07, 2023 - 10:46 EST
Monitoring
All Catchpoint services are back up, we are continuing to monitor for results.
Posted Mar 06, 2023 - 18:15 EST
Update
The Catchpoint Portal is available again. We are monitoring for stable results.

We are working to restore service for the API and WebPageTest services.
Posted Mar 06, 2023 - 14:35 EST
Update
We are nearing a resolution and will have an update here shortly.

We will keep you posted here every 30 minutes until the issue is resolved. Next update: 2:30 PM ET (unless we have a significant update before then).
Posted Mar 06, 2023 - 13:57 EST
Update
We are continuing to work on the resolution.

We will keep you posted here every 30 minutes until the issue is resolved. Next update: 1:50 PM ET (unless we have a significant update before then).
Posted Mar 06, 2023 - 13:22 EST
Update
We have identified the root cause and are working on a resolution.

We will keep you posted here every 30 minutes until the issue is resolved. Next update: 1:20 PM ET (unless we have a significant update before then).
Posted Mar 06, 2023 - 12:50 EST
Investigating
We are aware of an issue accessing the Catchpoint Portal. We will post updates as we receive more information.
Posted Mar 06, 2023 - 11:03 EST
This incident affected: Portal and Data Pull API.