Check out our Nodes Statuspage here ➜
Catchpoint Systems Services

Issue Affecting Test Data Analysis for a Subset of Customers

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 09:29 EST

Monitoring

A fix has been applied, and we are currently monitoring the results. Users should no longer encounter the error.
Posted Nov 17, 2025 - 04:35 EST

Investigating

We are currently investigating an issue impacting a subset of our customers.

Users may experience difficulties when analyzing their test data. Our team is actively working to identify the cause and restore full functionality. We will share further updates as more information becomes available.
Posted Nov 17, 2025 - 04:21 EST
This incident affected: Portal and Application Data.