Check out our Nodes Statuspage here ➜
Catchpoint Systems Services

Chrome Tests Version Issue

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 23:10 EDT

Monitoring

Some Chrome-based tests were temporarily switched to Chrome Stable Version 89 between March 10, 2026 – 19:52 UTC and 20:15 UTC. As a result, tests configured to run on a higher Chrome browser version may have experienced failures during this time due to the version downgrade impacting monitoring behaviour. The issue has been resolved and all affected tests have been restored to their intended configurations.
Posted Mar 10, 2026 - 17:53 EDT
This incident affected: Application Data.