Check out our Nodes Statuspage here ➜
Catchpoint Systems Services

Client Observer users unable to use the portal.

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 08:28 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2025 - 13:57 EST

Investigating

We are currently investigating an issue impacting users with Client Observer access, preventing them from using the portal. Our teams are actively working to restore functionality as quickly as possible.
Posted Nov 28, 2025 - 13:46 EST
This incident affected: Portal.