Check out our Nodes Statuspage here ➜
Catchpoint Systems Services

Temporary Service Degradation for Some Enterprise Node Customers

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 07:14 EDT

Monitoring

We have identified and resolved an issue that affected a subset of enterprise node customers between 07:09 and 08:42 UTC.

Our investigation confirms that there was no impact to customer data.

All services are now operating normally. We will continue to monitor the system to ensure stability.
Posted Apr 21, 2026 - 04:51 EDT