Check out our Nodes Statuspage here ➜
Catchpoint Systems Services

Portal slowness

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Dec 02, 2023 - 08:40 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 30, 2023 - 13:39 EST

Investigating

We are investigating an issue with portal slowness impacting a small set of customers. We’ll post more updates here as they become available.
If you’re experiencing any issue, please contact us at support@catchpoint.com
Posted Nov 30, 2023 - 12:35 EST
This incident affected: Portal.