Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Slowness in loading Screenshot and Filmstrip in the Catchpoint Portal
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Jan 20, 2025 - 10:05 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 20, 2025 - 08:23 EST
Investigating
We are currently investigating an issue causing slowness when accessing screenshots and filmstrip within the Records section of the Portal.

Please be assured that our team is actively identifying the cause and working diligently to implement a resolution as quickly as possible.
Posted Jan 20, 2025 - 08:10 EST
This incident affected: Portal and Instant Test.