Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
SSL issue with Let's Encrypt certificates
Incident Report for Catchpoint Systems Services Page
Resolved
We have completed the certificate update on the impacted nodes.

In addition there is another Let's Encyrpt root certificate expiring on 09/30. This is not expected to cause any issues but we are keeping a close vigil to ensure that there is no impact.
Posted Sep 30, 2021 - 02:06 EDT
Identified
We identified the issue is due to an expired intermediate certificate of Let's Encrypt which was present in Windows OS and distributed from Microsoft. This did not impact IE or Chrome, but it did impact the monitors that rely on cURL on this OS. This is because cURL uses a different prioritization scheme to select the trust chain for certificate validation. We are working to resolve this on our nodes by removing the offending certificate.

Devices can also encounter this issue if their devices have not downloaded the latest CA certificates from the OS manufacturer. Companies whose customers are impacted should make sure that the latest OS patches have been installed, or reach out to Let’s Encrypt for assistance.

We will update the status once the certificate update has been completed on all impacted nodes.

Some related posts:

https://marketresearchtelecast.com/lets-encrypt-certificates-stuttering-possible-on-september-30th/164576/
https://twitter.com/Scott_Helme/status/1443293844292919304
https://community.letsencrypt.org/t/help-thread-for-dst-root-ca-x3-expiration-september-2021/149190/211
Posted Sep 29, 2021 - 19:01 EDT
Update
We are continuing to investigate this issue.
Posted Sep 29, 2021 - 17:23 EDT
Investigating
We’re investigating an SSL issue for sites that use Let’s Encrypt certificates causing object and API tests to fail for some of our clients.

We will update here as more information become available.

Please contact us at support@catchpoint.com if you have any questions.
Posted Sep 29, 2021 - 17:23 EDT
This incident affected: Application Data.