Check out our Nodes Statuspage here ➜
Catchpoint Systems Services

APAC Node Test Execution Disruption (Excluding China)

Incident Report for Catchpoint Systems Services Page

Monitoring

A fix was implemented around 11:46 UTC for the issue. Data collection and test execution have resumed, and we are continuing to monitor the services.
Posted May 08, 2026 - 08:12 EDT

Investigating

We are currently investigating an issue affecting nodes in the APAC region (excluding China) that began around 11:20 UTC. Impacted nodes may not be running tests as expected. Our team is actively working to resolve the issue and restore normal operations.
Posted May 08, 2026 - 07:53 EDT
This incident affects: Application Data.