Check out our Nodes Statuspage here ➜
Catchpoint Systems Services

Issue loading data in Record, Smartboard and API

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 05:46 EDT

Monitoring

We identified an issue that affected a small number of users and API requests, impacting data loading on Record, Smartboard, and the REST API between 10:07 and 10:17 ET. A fix has been deployed and the issue is now resolved. We are continuing to monitor the system to ensure stability.
Posted Apr 29, 2026 - 10:39 EDT
This incident affected: Portal and Data Pull API.