Check out our Nodes Statuspage here ➜
Catchpoint Systems Services

UltraDNS (Neustar) North America outage

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted May 06, 2021 - 17:33 EDT

Monitoring

We’re monitoring an UltraDNS (Neustar) outage in North America, some of your test results might be impacted by this outage, for more information please go to the Neustar status page below.

https://www.home.neustar/ultradns-status

This is not a Catchpoint issue, this is informational only.

Please contact us at support@catchpoint.com if you have any questions.

Thanks.
Posted May 06, 2021 - 15:28 EDT