Check out our Nodes Statuspage here ➜
Catchpoint Systems Services
Intermittent Slowness while accessing the Catchpoint Portal
Incident Report for Catchpoint Systems Services Page
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 16:30 EST
Investigating
We are currently investigating intermittent slowness while accessing some of the Catchpoint portal modules.

Rest assured that our team is actively investigating the cause and working on a fix to restore full functionality as quickly as possible.
Posted Nov 18, 2024 - 10:47 EST
This incident affected: Portal.