Check out our Nodes Statuspage here ➜
Catchpoint Systems Services

Help Center Access Issue

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 17:20 EDT

Investigating

We are currently aware of an issue preventing Catchpoint users from accessing the Help Center via the portal. In the meantime, you can still reach our support team through the https://support.catchpoint.com/hc/en-us/ or by emailing us directly at support@catchpoint.com.
Posted Jun 12, 2025 - 15:56 EDT
This incident affected: Catchpoint Help Center.