Check out our Nodes Statuspage here ➜
Catchpoint Systems Services

Capture Historical Data Issue US-WEST

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Jan 16, 2026 - 09:29 EST

Investigating

A subset of historical capture data in the US-West region is currently unavailable.
All real-time capture data is working expected.
Posted Jan 16, 2026 - 01:52 EST