Check out our Nodes Statuspage here ➜
Catchpoint Systems Services

Catchpoint Portal is Currently Down

Incident Report for Catchpoint Systems Services Page

Resolved

This incident has been resolved.
Posted Jun 08, 2021 - 10:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2021 - 06:53 EDT

Identified

We have implemented a fix and removed CDN. Please expect degraded performance for some users.
Posted Jun 08, 2021 - 06:51 EDT

Investigating

Catchpoint Portal is currently down due to an issue with our CDN provider. We are working on it and will update accordingly.
Posted Jun 08, 2021 - 06:17 EDT
This incident affected: Portal.